№ 6536 (Уровень: Сложный)
(Д. Статный, М. Шагитов) Сколько существует восьмиразрядных чисел, 
записанных в шестнадцатеричной системе счисления и содержащих только 3 чётные цифры.

Рекурсия:
def f(code, ch, nh):
    if code==8 and ch==3:
            return 1
    if code==8 and ch!=3:
            return 0
    d = []
    if code==0: d.append(f(code+1,ch+1,nh)*7)
    elif code>0: d.append(f(code+1,ch+1,nh)*8)
    d.append(f(code + 1, ch, nh+1)*8)
    return sum(d)
print(f(0,0,0))

Перебор:
